1. THÔNG BÁO TUYỂN ADMIN DIỄN ĐÀN 2013
    Tìm kiếm nhà trọ - Ở ghép
    THÔNG BÁO BÁN ÁO SPKT.NET CHO THÀNH VIÊN DIỄN ĐÀN


    HÃY TÌM KIẾM Ở ĐÂY TRƯỚC KHI ĐẶT CÂU HỎI
    {xen:phrase loading}

[hệ thống nhúng]Không cài đặt được rootfs lên kit SAM9260..help me !

Thảo luận trong 'Lập trình nhúng' bắt đầu bởi BuiKhacTri, 8 Tháng tư 2012.

  1. BuiKhacTri New Member

    Số bài viết: 6
    Đã được thích: 0
    Điểm thành tích: 0
    khi t nạp rootfs từ lệnh tftp 0x20000000 Angstrom-console-image-demo-glibc.rootfs.jffs2 .thì nó vẫn load nhưng được 1 chút là báo macb0 TX timeout dù t đã kiểm tra thiết lập địa chỉ ethernet chạy vẫn tốt.hic
    [IMG]
  2. BuiKhacTri New Member

    Số bài viết: 6
    Đã được thích: 0
    Điểm thành tích: 0
  3. truongvanquan New Member

    Số bài viết: 10
    Đã được thích: 0
    Điểm thành tích: 0
    Theo kinh nghiện của e thì:
    a ko nên truyền rootfs hay kernel qua ethernet -> RAM -> NANDFLASH!
    Hay bị hỏng, bad lắm.
    Hãy nạp kernel và rootfs qua SAMBA sẽ đảm bảo hơn.

    Lỗi thứ 2 là do rootfs toi rùi. :D -> nạp lại qua SAMBA cho chắc.
  4. BuiKhacTri New Member

    Số bài viết: 6
    Đã được thích: 0
    Điểm thành tích: 0
    a cũng nạp từ SAMBA luôn rùi.nhưng nó vẫn bị lỗi thứ 2 đó.vô nhân chạy được 1 tí là báo lỗi.
  5. linhdong Member

    Số bài viết: 306
    Đã được thích: 6
    Điểm thành tích: 18
    Giới tính: Nam
    Hok biết có phải do nand hay không?hôm qua sửa cho bác chạy ngon lành rồi mà,có báo lỗi gì đâu,sao đem về lại bị nữa vậy..?Sao cứ chập chờn thế hok biết..!
  6. kamejoko80 New Member

    Số bài viết: 17
    Đã được thích: 0
    Điểm thành tích: 0
    1> Lỗi thứ nhất : Nhìn trên bootlog thì thấy ethernet bị chập chờn, kiểm tra lại phần ethernet xem thế nào.

    2> Lỗi thứ 2: Có 2 tình huống có thể đoán ra:
    - Quá trình load roofs vào SDRAM bị failed, đương nhiên lúc boot sẽ có báo lỗi.
    - Khai báo sai biến môi trường bootagrs.

    Nên xem lại phần cứng ethernet, nguyên nhân không boot được có thể xuất phát từ phần đó. Chi tiết cách boot linux cho board KM9260 có thể tham khảo link sau:

    http://code.google.com/p/km9260/wiki/KM9260_Boot_Recovery
  7. BuiKhacTri New Member

    Số bài viết: 6
    Đã được thích: 0
    Điểm thành tích: 0
    anh ơi.e thường đi trường hợp này.khi e dùng kernel có nhân linux 2.6.27 thì vô được nhưng khi dùng linux 2.6.30 thì bị đứng,anh giúp e nhe
    [IMG]
  8. hungson3 New Member

    Số bài viết: 6
    Đã được thích: 0
    Điểm thành tích: 1
    Mình cũng đã từng bị như bạn và đx sửa thành công, nói chung là nó có khá nhiều lổi lặt vặt nên không thể nói hết được phải tùy từng trường hợp cụ thể, đây là yahoo mình: henryson339
    mình sẻ kiểm tra giúp cho :)
  9. BuiKhacTri New Member

    Số bài viết: 6
    Đã được thích: 0
    Điểm thành tích: 0
    mình khắc phục được rùi....thanks bạn nhiều nhe............

Chia sẻ trang này