1. THÔNG BÁO TUYỂN ADMIN DIỄN ĐÀN 2013
    Tìm kiếm nhà trọ - Ở ghép
    THÔNG BÁO BÁN ÁO SPKT.NET CHO THÀNH VIÊN DIỄN ĐÀN


    HÃY TÌM KIẾM Ở ĐÂY TRƯỚC KHI ĐẶT CÂU HỎI
    {xen:phrase loading}

Lỗi fuse bits khi dùng mạch nạp USB...Hjx :(

Thảo luận trong 'Lập trình C cho vi điều khiển AVR cơ bản' bắt đầu bởi Junior, 12 Tháng mười một 2009.

  1. Junior New Member

    Số bài viết: 196
    Đã được thích: 0
    Điểm thành tích: 0
    [IMG]
    Con ATmega8 mình cần dùng thêm chân PC6 làm I/O nên set fuse bit ResetDisable :fortunecat:
    AVRProg nó set lên 1 cái rồi đi con AT lun, chẳng còn program j đc nữa :027:
    Có cao thủ nào biết về vấn đề này chỉ giúp mình với
    Hjx..... :011:
  2. daihoa New Member

    Số bài viết: 184
    Đã được thích: 1
    Điểm thành tích: 0
    cái này thì con at của bạn chưa die đâu, nó vẫn còn xài được nhưng bạn phải mở lock bit nó, cái này bạn phải nhờ thầy cường ở khoa học trẻ giải quyết giúp cho,
  3. Junior New Member

    Số bài viết: 196
    Đã được thích: 0
    Điểm thành tích: 0
    Dùng mạch nạp USB thấy hạn chế quá
    Nếu dùng mạch nạp qua cổng LPT chắc chẳng gặp phải mấy chyện thế này đâu nhỉ ?!
    :surrenders:
  4. daihoa New Member

    Số bài viết: 184
    Đã được thích: 1
    Điểm thành tích: 0
    đúng là mạch nạp usb nó hạn chế về điều này nhưng nó rất tiện lợi về nhiều mặt bạn ah, nếu bạn dùng laptop mà ko có mạch nạp usb thì làm sao bạn có thể lập trình đc, đồng thời đối với máy tính bàn thì nó cũng dễ sứ dụng hơn vì cổng lpt chỉ có 1, còn usb thì có nhiều cổng, thuận tiện cho việc kết nối
  5. Junior New Member

    Số bài viết: 196
    Đã được thích: 0
    Điểm thành tích: 0
    Bạn nói đúng...
    Mạch nạp USB có ưu điểm riêng của nó
    Với ai dùng desktop thì mạch nạp LPT thuận tiện hơn
    Tốt nhất là nên có cả 2 cái để phòng trường hợp đặc biệt :001:
  6. winwi New Member

    Số bài viết: 2
    Đã được thích: 0
    Điểm thành tích: 0
    Con Atemega8 của ông chưa chết đâu.Có lẽ do trước khi check vao Reset Disable ông chưa Read lại cấu hình của nó trước đó.Rồi check reset disable-->Write--> vậy là quên check SPI enable-->con atm8 ko program ở chế độ ISP được nữa:027:.(ko biết có phải ông bị vậy ko:007:)


    [IMG]
    Để set lại fuse bit SPIEN phải dùng bộ nạp mode parallel programming (STK500):eek:k:
  7. kipo00 New Member

    Số bài viết: 2
    Đã được thích: 0
    Điểm thành tích: 0
    mình cũng có 3 con atmega8 đang treo nè thử đủ mọi cách mà chưa cứu dc nữa ^^
    có pro nào có kinh nghiệm xin chỉ dùm.... thank
  8. otacon New Member

    Số bài viết: 5
    Đã được thích: 0
    Điểm thành tích: 1

Chia sẻ trang này